[Linux-stm32] [PATCH 00/15] ASoC: replace dpcm_playback/capture to playback/capture_only
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Wed Mar 27 01:26:53 UTC 2024
Hi Amadeusz
> One general note, I wonder if playback/capture_only should be renamed to
> something more descriptive, current names are a bit weird from use case
> point of view. I mean no flags, means both capture and playback are
> enabled. Then you do something like playback_only = 1, which effectively
> affects capture stream. Notice that flag is named playback, but affects
> capture. Perhaps, something like capture_disabled, playback_disabled
> would make more sense? This would also make more sense to me for
> something like playback_only = 1; capture_only = 1; which while weird
> doesn't instantly seem that wrong, while disable on both directions
> instantly seems broken.
This patch-set is just using existing style, no special intention.
Basically, I have no special objection about _only vs _disabled,
but I think it will be 50:50 no matter which style we choose.
But switching "_only" into "_disabled" should be another patch-set,
I think. But I'm happy to do it if everyone want it.
Thank you for your help !!
Best regards
---
Renesas Electronics
Ph.D. Kuninori Morimoto
More information about the Linux-stm32
mailing list