[Linux-stm32] [PATCH 00/15] ASoC: replace dpcm_playback/capture to playback/capture_only
Amadeusz Sławiński
amadeuszx.slawinski at linux.intel.com
Tue Mar 26 12:25:38 UTC 2024
On 3/25/2024 5:35 AM, Kuninori Morimoto wrote:
>
> Hi Mark
>
> When we use DPCM, we need to set dpcm_playback/capture flag.
> If these flag are set, soc_get_playback_capture() will check its
> availability, but non DPCM case is checked without special flags.
>
> OTOH, it cares playback/capture_only flag. It is needed.
>
> This patch remove DPCM special flag, and replace it playback/capture_only
> flag if needed.
>
One general note, I wonder if playback/capture_only should be renamed to
something more descriptive, current names are a bit weird from use case
point of view. I mean no flags, means both capture and playback are
enabled. Then you do something like playback_only = 1, which effectively
affects capture stream. Notice that flag is named playback, but affects
capture. Perhaps, something like capture_disabled, playback_disabled
would make more sense? This would also make more sense to me for
something like playback_only = 1; capture_only = 1; which while weird
doesn't instantly seem that wrong, while disable on both directions
instantly seems broken.
More information about the Linux-stm32
mailing list