[Linux-stm32] [PATCH] coresight: do not use the BIT() macro in the UAPI header

Greg Kroah-Hartman gregkh at linuxfoundation.org
Tue Mar 24 06:28:53 UTC 2020


On Tue, Mar 24, 2020 at 05:22:13AM +0100, Eugene Syromiatnikov wrote:
> The BIT() macro definition is not available for the UAPI headers
> (moreover, it can be defined differently in the user space); replace
> its usage with the _BITUL() macro that is defined in <linux/const.h>.

Why is somehow _BITUL() ok to use here instead?

Just open-code it, I didn't think we could use any BIT()-like macros in
uapi .h files.

thanks,

greg k-h



More information about the Linux-stm32 mailing list