[Linux-stm32] [PATCH][next] net: stmmac: selftests: Use struct_size() helper in kzalloc()

David Miller davem at davemloft.net
Fri Jun 19 03:19:41 UTC 2020


From: "Gustavo A. R. Silva" <gustavoars at kernel.org>
Date: Tue, 16 Jun 2020 18:03:28 -0500

> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars at kernel.org>

Applied to net-next, thanks.



More information about the Linux-stm32 mailing list