[Linux-stm32] [PATCH net-next v5] net: page_pool: API cleanup and comments

David Miller davem at davemloft.net
Thu Feb 20 18:09:38 UTC 2020


From: Ilias Apalodimas <ilias.apalodimas at linaro.org>
Date: Thu, 20 Feb 2020 09:41:55 +0200

> Functions starting with __ usually indicate those which are exported,
> but should not be called directly. Update some of those declared in the
> API and make it more readable.
> 
> page_pool_unmap_page() and page_pool_release_page() were doing
> exactly the same thing calling __page_pool_clean_page().  Let's
> rename __page_pool_clean_page() to page_pool_release_page() and
> export it in order to show up on perf logs and get rid of
> page_pool_unmap_page().
> 
> Finally rename __page_pool_put_page() to page_pool_put_page() since we
> can now directly call it from drivers and rename the existing
> page_pool_put_page() to page_pool_put_full_page() since they do the same
> thing but the latter is trying to sync the full DMA area.
> 
> This patch also updates netsec, mvneta and stmmac drivers which use
> those functions.
> 
> Suggested-by: Jonathan Lemon <jonathan.lemon at gmail.com>
> Acked-by: Toke Høiland-Jørgensen <toke at redhat.com>
> Acked-by: Jesper Dangaard Brouer <brouer at redhat.com>
> Signed-off-by: Ilias Apalodimas <ilias.apalodimas at linaro.org>

Applied, thanks Ilias.



More information about the Linux-stm32 mailing list