[Linux-stm32] [PATCH net-next] net: page_pool: API cleanup and comments

David Miller davem at davemloft.net
Mon Feb 17 03:53:00 UTC 2020


From: Ilias Apalodimas <ilias.apalodimas at linaro.org>
Date: Sun, 16 Feb 2020 11:40:55 +0200

> Functions starting with __ usually indicate those which are exported,
> but should not be called directly. Update some of those declared in the
> API and make it more readable.
> 
> page_pool_unmap_page() and page_pool_release_page() were doing
> exactly the same thing. Keep the page_pool_release_page() variant
> and export it in order to show up on perf logs.
> Finally rename __page_pool_put_page() to page_pool_put_page() since we
> can now directly call it from drivers and rename the existing
> page_pool_put_page() to page_pool_put_full_page() since they do the same
> thing but the latter is trying to sync the full DMA area.
> 
> Also update netsec, mvneta and stmmac drivers which use those functions.
> 
> Suggested-by: Jonathan Lemon <jonathan.lemon at gmail.com>
> Signed-off-by: Ilias Apalodimas <ilias.apalodimas at linaro.org>

Applied to net-next, thanks.



More information about the Linux-stm32 mailing list