[Linux-stm32] [PATCH 2/3] mmc: Return 1 from mmc_set_signal_voltage() if switch skipped
Ulf Hansson
ulf.hansson at linaro.org
Wed Apr 15 08:40:22 UTC 2020
On Wed, 1 Apr 2020 at 21:57, Marek Vasut <marex at denx.de> wrote:
>
> Adjust mmc_set_signal_voltage() to return 1 if the voltage switch was
> skipped because the regulator voltage was already correct. This allows
> drivers to detect such condition and possibly skip various voltage
> switching extras.
This change to the code isn't about mmc_set_signal_voltage(), but
about mmc_regulator_set_voltage_if_supported(). Please update the
changelog to reflect this.
Moreover, as a part of $subject patch, you also need to adopt
mmc_regulator_set_vqmmc() to cope with the new behaviour of
mmc_regulator_set_voltage_if_supported().
>
> Signed-off-by: Marek Vasut <marex at denx.de>
> Cc: Alexandre Torgue <alexandre.torgue at st.com>
> Cc: Linus Walleij <linus.walleij at linaro.org>
> Cc: Ludovic Barre <ludovic.barre at st.com>
> Cc: Manivannan Sadhasivam <manivannan.sadhasivam at linaro.org>
> Cc: Maxime Coquelin <mcoquelin.stm32 at gmail.com>
> Cc: Patrice Chotard <patrice.chotard at st.com>
> Cc: Patrick Delaunay <patrick.delaunay at st.com>
> Cc: Russell King <linux at armlinux.org.uk>
> Cc: Ulf Hansson <ulf.hansson at linaro.org>
> Cc: linux-stm32 at st-md-mailman.stormreply.com
> To: linux-mmc at vger.kernel.org
If possible, please drop all these, as I don't think we need them as
references part of the patch. Of course, it's easier for you to keep
them, I can also drop it while applying.
> ---
> drivers/mmc/core/regulator.c | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/drivers/mmc/core/regulator.c b/drivers/mmc/core/regulator.c
> index b6febbcf8978..2805ea8a070e 100644
> --- a/drivers/mmc/core/regulator.c
> +++ b/drivers/mmc/core/regulator.c
> @@ -136,6 +136,8 @@ static int mmc_regulator_set_voltage_if_supported(struct regulator *regulator,
> int min_uV, int target_uV,
> int max_uV)
> {
> + int curr_voltage;
Nitpick: To be consistent with other variable names, maybe current_uV
is a better name.
> +
> /*
> * Check if supported first to avoid errors since we may try several
> * signal levels during power up and don't want to show errors.
> @@ -143,6 +145,14 @@ static int mmc_regulator_set_voltage_if_supported(struct regulator *regulator,
> if (!regulator_is_supported_voltage(regulator, min_uV, max_uV))
> return -EINVAL;
>
> + /*
> + * The voltage is already set, no need to switch.
> + * Return 1 to indicate that no switch happened.
> + */
> + curr_voltage = regulator_get_voltage(regulator);
> + if (curr_voltage == target_uV)
> + return 1;
> +
> return regulator_set_voltage_triplet(regulator, min_uV, target_uV,
> max_uV);
> }
> --
> 2.25.1
>
Kind regards
Uffe
More information about the Linux-stm32
mailing list